Lync MVP

Lync MVP
MVP AWARD

Thursday, February 14, 2013

Fix for The WebReady Document Viewing service has been disabled by the administrator for your organization

I got it finally solved:
Well there are more issues compared to simple resting services.
Here what you have to do:

1. follow exactly Microsoft setup guide ! : http://technet.microsoft.com/library/2591b1be-92c4-4192-9f5e-e4e6b319170a

2. as its recommended to chose SSL in production environment, you need to validate the discovery point incl HTTPS !! not like described by MSFT with http, if its not enabled. mostly you will see an Certificate Error, because the Cert you requested via IIS is not a valid Cert incl a SAN Name:
Make sue you have: the hostname, hostname.domain.com in this certificate and assign it to HTTP80 and HTTP809 SSL Services.


3. run IISRESET

4. you properly see issues with the Watchdog, check the log under: C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS if you see the Watchdog is accessing the WAC Server via HTTP, you need add the Port 80 under HTTP80 WebSite. I believe its a bug here.

5. IISRESET again

6. check now from OWA if it works or not, if not you need to restart Exchange 2013. It refers the Discovery Point.

Once more this environment was OS: W2k12 and Exchange 2013.

Good Luck !!
Thomas



















2 comments:

  1. i recently installed exchange 2013CU1 in my existing exchange 2010 setup. i am able to view all word, excel pdf from owa without installing office web app server. how? why?

    the same thing does not work with my client site. i don't want to install office web app server . what is the solution

    ReplyDelete
  2. Hi Snehal,

    there are several things you need to take care about.
    1. if you migrate, it depends where the mailbox is located. also how you have setup the OWA / CAS Server.

    Fact is, Exchange 2013 OWA must make use of the WAC Server. there is NO engine coming with Exchange 2013 anymore. this is one of the major changes in Office 2013 Servers.

    In you case, if you still be able to view documents, you are still connected to the OWA on Exchange 2010. You might have a look. Even if you are connecting to the OWA 2013, you might be redirected back to OWA 2010. Possible because of the Mailbox might be still on E2k10

    Hope I could help you

    ReplyDelete